Axial AE-2 ESC Set-up and Programming

By Axial on Aug 18, 2011

blog_ae-2_esc_500x220

Set-up tips for installing and programming Axial’s AE-2 ESC.

Set-up:

1. Mount ESC in an area that is well ventilated, and isolated from vibration and shock.

2. Connect ESC wires to the motor(s).

3. Plug the receiver wire into the throttle channel on your receiver.

4. Before plugging the battery into the ESC, make sure your transmitter is on and that the throttle trim is set to zero.

5. Double check that the battery wires on the ESC are wired correctly, red on red and black on black. **Reversing the polarity will permanently damage the ESC**

6. Plug the battery into the ESC, with the ESC switch in the “off” position.

7. Apply full throttle on the transmitter.

8. Turn the ESC on while applying full throttle.

9. The ESC will emit a series of beeps through the motor with the “Red” LED.

10. Continue applying full throttle until the ESC blinks “Green” and emits a series of beeps to finalize the full throttle endpoint.

11. Once the ESC blinks “Red”, apply full brake/reverse, and hold.

12. The ESC will emit a series of beeps while blinking “Red” to finalize the reverse/brake endpoint.

13. Return the throttle to neutral and the ESC will emit a series of beeps to finalize the neutral point.

14. The ESC will emit one last series of beeps confirming the ESC is ready to go.

15. Apply throttle to make sure motor turns in the proper direction. To reverse the direction of the motor, switch the wires going to the motor.

Notes:

1. If ESC set-up does not initialize while holding full throttle, try switching the throttle reverse switch on the transmitter. Also double check that the throttle trim is still set to zero.

2. Lipo “Cut-off” is set to “On” from the factory.

3. Use the “Castle Link” to access the advanced settings in this ESC.

Specifications:

Input Voltage – 6 cell NiCad/NiMH or 2cell lipo**

Size – 1.7″ x 1.24″

Weight – 45 Grams

Motor Limit – 19t

On-Resistance FET – .0018

Rated/Peak Current – 106A Peak

Braking Current – 106A Peak

BEC Voltage – 5.0V/2A Peak

PWM Frequency – 6KHZ

**You can run higher voltage batteries such as a 7 cell NiCad/NiMH or 3 cell lipo with the installation of a “Castle BEC”

Manually programming Axial’s AE-2 ESC

Here are a few tips for programming Axial’s AE-2 ESC, without a computer or “Castle Link”.

You can manually adjust 3 of the most important settings in the AE-2 ESC.

1. Lipo Cut-off

2. Drag Brake

3. Reverse

Manual programming

Follow these steps to change settings on your Axial AE-2 ESC without a computer.

*Remove your pinion gear before calibration and manual programming as a safety precaution!*

STEP 1: Start with the transmitter ON and the ESC switched OFF and not connected to the battery.

STEP 2: Plug a battery into the ESC. Hold full throttle on the transmitter and turn the ESC switch ON. After a few seconds you will get the four rings in a row signaling full throttle calibration. Keep on holding full throttle. After a few more seconds, you will hear another four rings in a row. After the second group of four rings, relax the throttle to neutral. If you have successfully entered programming mode, the ESC will beep twice, pause, and repeat the two beeps.

STEP 3: The programming sequence is always presented in sequential order and always starts with the first setting (None) within the first section (Voltage Cutoff). The first beep(s) signifies which section of the programming you are in and the second beep(s) signifies which setting is waiting for a “yes” or “no” answer. As you go sequentially through the options, you will need to answer “yes” by holding full throttle, or answer “no” by holding full brake until the ESC accepts your answer by beeping rapidly. Once an answer has been accepted, relax the throttle back to neutral for the next question. After a “no” answer is accepted, the ESC will then present you with the next option in that section. After a “yes” answer is accepted, the ESC knows you aren’t interested in any other option in that section, so it skips to the first option in the next section.

Settings and explanations

The following section explains all the settings available to you via manual programming and what each one does to change the reactions of the ESC in order to tune it to your specific preferences. More settings are available via “Castle Link”.

1. Cutoff Voltage

Sets the voltage at which the ESC lowers or removes power to the motor in order to either keep the battery at a safe minimum voltage (Lithium Polymer cells) or the radio system working reliably (NiCad/NiMH cells).

Setting 1: None

Does not cut off or limit the motor due to low voltage. Do not use with any Lithium Polymer packs!

Use this setting ONLY with NiCad or NiMH packs. With continued driving, the radio system may eventually cease to deliver pulses to the servo and ESC, and the vehicle will not be under control.

You will irreversibly damage Lithium Polymer packs with this setting!

Setting 2: Auto-LiPo (Default)

This setting allows you to go back and forth between 2 and 3 cell LiPo packs without having to change the cutoff voltage for each one. The ESC automatically sets the cutoff voltage correctly for a 2 or 3 cell pack when that pack is plugged in.

2. Drag Brake

Sets the amount of drag brake applied at neutral throttle to simulate the slight braking effect of a neutral brushed motor while coasting.

Setting 1: Drag Brake OFF

Vehicle will coast with almost no resistance from the motor at neutral throttle.

Setting 2: Drag Brake 15%

Very Low amount of braking effect from the motor at neutral throttle

Setting 3: Drag brake 25%

Low amount of braking effect from the motor at neutral throttle

Setting 4: Drag Brake 40%

More braking effect from the motor at neutral throttle.

Setting 5: Drag Brake 50%

Fairly high braking effect from the motor at neutral throttle.

Setting 6: Drag Brake 100% (Default)

Full braking effect from the motor at neutral throttle.

3. Brake / Reverse Type

Sets whether reverse is enabled or not, and exactly how it can be accessed.

Setting 1: Reverse Lockout

This setting allows the use of reverse only after the ESC senses two seconds of neutral throttle. Use it for race practice sessions and bashing, but check with your race director to see if this setting is allowed for actual racing.

Setting 2: Forward/Brake Only

Use this setting for actual sanctioned racing events. Reverse cannot be accessed under any circumstances with this setting.

Setting 3: Forward/Brake/Reverse (Default)

Reverse or forward is accessible at any time after the ESC brakes to zero motor RPM.

Axial Car ESC Programming Reference:

1: Voltage Cutoff

Option 1 : None

Option 2 : Auto-LiPo (D)*

2: Drag Brake

Option 1 : Disabled

Option 2 : 15%

Option 3 : 25%

Option 4 : 40%

Option 5 : 50%

Option 6: 100% (D)*

3: Brake/Reverse Type

Option 1 : Reverse Lockout

Option 2 : Forward/Brake Only

Option 3 : Forward/Brake/Reverse (D)*

(D)* = Default setting from the factory


62 Comments:

  1. Default_avatar Chong Shing Posted on 2011-09-28 07:26:33

    Please let me know , this ESC AE-2 is water proof , thanks…

  2. Default_avatar Bender Posted on 2011-09-29 09:02:22

    It’s not waterproof. Your best bet is to use some balloons if you want to submerse your vehicle.

  3. Default_avatar carlos michel Posted on 2011-10-09 12:11:24

    plese help me, can i run 6-cell batteries 8.4v on the ae-2 esc??

  4. Default_avatar Bender Posted on 2011-10-11 08:10:05

    The 8.4 volt batteries are usually 7 cell, not 6 cell. But, either way the AE-2 ESC will be fine.

  5. Default_avatar patrick auger Posted on 2011-10-12 17:10:47

    What you do to finish the manual programming??? Shut the transmitter off, shut the ESC off???

    Thanks for the help

  6. Default_avatar patrick auger Posted on 2011-10-13 03:23:05

    What hapend when everything is done…..you just switch the transmitter off and the ESC off???

    Thanks for replying

  7. Default_avatar Bender Posted on 2011-10-13 07:55:50

    Shut the ESC off first, then the transmitter.

  8. Default_avatar Bender Posted on 2011-10-13 07:57:04

    After you are done running your truck, shut the ESC off first, then the transmitter. Then always unplug your batteries too.

  9. Default_avatar patrick auger Posted on 2011-10-19 14:10:28

    I fallow all the step by step and can’t get in the programming….I heard the four rings and 2 ring at the beginning………( the 2 rings is after a second or two) i still hold full trottle…….waiting for the second four ring………..but never heard a second 4 rings after a few seconds…..

    Please Help

    Patrick

  10. Default_avatar patrick auger Posted on 2011-10-20 03:22:57

    Update..

    After a couple of try of the step by step…..I can’t understand why is not working for me. I found that getting in the manual programming……i have to make FULL REVERSE and BANG i’m in. I had to realize again that my YES was FULL REVERSE and my NO was FULL THROTTLE. After it was done the first time, i try the Wraith and realize that my Drag brake was setting at 50% instead of 100% from the default set up. So i try again to get in the programming…..BUT this time I CANT GET IN that easy with FULL REVERSE…because the truck made RING sound NON-STOP. I repeat AGAIN the procedure….same thing. After a couple of try…when i heard the NON-STOP RING…….i make FULL THROTTLE and FULL REVERSE……and I get in the programming again.

    Patrick

  11. Default_avatar ziig zagg Posted on 2011-10-20 12:56:39

    hey,

    if I set my options by remot controll the next timer I go through the esc menue all settings are set to the first of those three main groups. 1=1 2=1 3=1.How can I be sure the the lipo cut off is active at the next riding session. or is this behavior usal?

    greez from germany

  12. Default_avatar Bender Posted on 2011-10-24 16:43:48

    Try contacting out customer service department at 949-600-8642. They can help guide you through the programming process.

  13. Default_avatar Bender Posted on 2011-10-24 16:45:15

    Try contacting out customer service department at 949-600-8642. They can help guide you through the programming process. It may be resetting itself every time you enter program mode.

  14. Default_avatar Ryan Posted on 2011-10-26 10:12:11

    Hi

    Just want to ask can u run 2 motors on AE-2 ESC

  15. Default_avatar Tom Posted on 2011-11-03 13:55:33

    Hi,

    Is it possible to set up this ESC such that the max speed is limited?

    I just spoke on the phone to someone in a shop that said there is a button you press while you hold the throttle trigger at the desired max speed and then it won;t go over that speed under normal use.

    I want to know as I want to let my 3yo son play with it from time to time without doing huge damage :)

    Thanks,

    Tom…

  16. Default_avatar Matt Posted on 2011-11-04 01:03:48

    I tried cleaning my Wraith today, and unplugged my radio and servo. Pluged it back in and it started tweeking out, So I just tried to re program it and it flashed red and green and didn’t quit beeping. I have no clue what to do next. Battery is charged, transmitter has good batteries, and I followed the instructions exactly. Is my ESC toast?

    Thanks

  17. Default_avatar Brian Posted on 2011-11-12 12:47:38

    This is a good write up saved my rear a few times. I have this esc in my sos truck and idk why but it unbinds or un programs it self about once every 1-2 months. Easy fix just wish I knew why it done this. Straight out the box Its done it.

  18. Default_avatar Brandon Posted on 2011-11-12 20:27:26

    When I program mine it programs but there is no reverse even though i select reverse option any help

  19. Default_avatar Bender Posted on 2011-11-14 09:18:49

    You can if they are higher turn motors like 55t. I built an XR10 using our AE-2 ESC with 55t motors, and it worked great.

  20. Default_avatar Bender Posted on 2011-11-14 09:20:35

    There isn’t that I know of. One tip that may help is taping some foam or something behind the throttle trigger, so he can’t pull the throttle wide open.

  21. Default_avatar Bender Posted on 2011-11-14 09:21:56

    No sure if your ESC is toast or not, try calling our customer service department, they might be able to help you get it going again. Phone number is 949-600-8642.

  22. Default_avatar Bender Posted on 2011-11-14 09:22:49

    That is weird, try calling our customer service department and let them know what issues you are having. 949-600-8642

  23. Default_avatar Bender Posted on 2011-11-14 09:24:01

    Hit up our customer service department, they should be able to get you squared away. 949-600-8642

  24. Default_avatar Richard.wang Posted on 2011-11-21 20:17:41

    I’m sure set AE-2 to 3-3 options(Forward/Brake/Reverse), and saved. but did not work! Same no brake function, still only forward and reverse! Why? Why? Why?

    My manual Settings are as follows:

    1: Voltage Cutoff

    Option 2 : Auto-LiPo (B,B-B ,then press Full throttle)

    2: Drag Brake

    Option 1 : Disabled (B-B,B ,then press Full throttle)

    3: Brake/Reverse Type

    Option 3 : Forward/Brake/Reverse (B-B-B,B-B-B ,then press Full throttle)

    step 4: relax the throttle back to neutral, waiting AE-2 Auto reboot.

  25. Default_avatar Richard.wang Posted on 2011-11-21 20:23:26

    Finally, my car is SCX10 – 90016, the factory configuration. No any changes.

  26. Default_avatar Bender Posted on 2011-11-22 08:04:25

    Make sure your throttle sub trim is set to zero when you do the initial set-up, otherwise it may not work properly. If you still have problems try contacting our customer service department at 949-600-8642.

  27. Default_avatar amo Posted on 2011-11-25 21:31:13

    Open the ESC switch, ESC B B B ….. B B. Then, the green light flashes. ESC not work.

  28. Default_avatar martin rheault Posted on 2011-11-27 19:08:21

    when for rock crawling yesthurday and a the end of my run the lipo cut off did is job. when home and charge the batt. after that turn the switch on for the truck and i soon i give some trothle everything shot off no light nothing.

    tonigh ì’ve try again i check the esc when i go foward a= i got red light and reverse green. do you have any idea what the problem

    thanks

  29. Default_avatar Murphy Posted on 2012-01-02 07:20:46

    Hi my Axial AX-10 was running fine yesterday Now it wont go fwd or rev. steering works fine

    is there a reset or what can i do. thanks

  30. Default_avatar Bender Posted on 2012-01-03 12:43:45

    Hi Murphy. Try contacting out customer service department at 949-600-8642.

  31. Default_avatar Bender Posted on 2012-01-03 12:44:31

    Hi Martin, sorry for the delay answering your question. Try contacting out customer service department at 949-600-8642, or email service@axialracing.com

  32. Default_avatar Shawn Schaff Posted on 2012-01-20 20:58:45

    Trying to change the LiPo cutoff from the factory settings. I’m following the above directions but when I turn the ESC on I get no beeps. Any idea what the problem could be?

  33. Default_avatar Bender Posted on 2012-01-23 10:04:18

    Try either emailing or calling our customer service department, they should be able to help. service@axialracing.com or 949-600-8642.

  34. Default_avatar Eric Posted on 2012-02-14 19:41:51

    I have gone through the manual setup up 5 times and everytime I turn off the ESC and the transmitter, then turn it back on, it goes back to 1-1, 2-1, 3-1. I cannot get the manual settings to stick….. What do I need to do?

  35. Default_avatar Bender Posted on 2012-02-15 08:08:44

    Try contacting out customer service department at 949-600-8642, or email service@axialracing.com

    They can help walk you through the process.

  36. Default_avatar hoopie Posted on 2012-02-15 20:26:52

    my scx 10 honcho cuts off when i try to go over obstacles and has no power and then will get bursts of power out of no where. i just took it out of the box and have only drove it in the living room whats wrong with it?

  37. Default_avatar Bender Posted on 2012-02-16 08:23:43

    Try contacting out customer service department at 949-600-8642, or email service@axialracing.com they can help you sort out the issue.

  38. Default_avatar touhami altouhami Posted on 2012-02-19 22:01:05

    The car is amazing indeed compared to my other RC cars. However I have some issues. I bought my SCX10 Hanco from rcmart.com few weeks ago and received it just last week. Anyhow when I tried to run the SCX10 the transmitter and receiver is not working at all, though I already informed the seller about it but unfortunately didnt get a solution.

    Im sort of disappointed though for the lack of response. Anyway, I removed the receiver and replaced it with the one I am using with my Tamiya CC01,,,, wallah!!! IT DID WORK PERFECTLY! Since, obviously there is a factory defect I would like to have a replacement of the transmitter and receiver the soonest.

    BTW Im currently living here in Jeddah, Saudi Arabia so I cant call your costumer service.

    Appreciate your prompt response.

    Thanks,

    Touhami Altouhami

  39. Default_avatar Bender Posted on 2012-02-21 10:37:54

    Hello Touhami,

    Try emailing our customer service department, they can break down the radio binding process for you. service@axialracing.com

    We also recently posted a couple “how to” videos to youtube explaining the binding and ESC calibration processes.

    Radio:

    http://www.youtube.com/watch?v=jv2cjMyC34g&feature=g-all-u&context=G2a4b52cFAAAAAAAAAAA

    ESC:

    http://www.youtube.com/watch?v=cFLKaA1a7fQ&feature=g-all-u&context=G2a4b52cFAAAAAAAAAAA

  40. Default_avatar daniel Posted on 2012-02-25 11:07:10

    I have tried to program esc for turning off lip detection… failed. Tried to setup and failed. Steering works but no forward or reverse. Brand new scx10 honcho.

  41. Default_avatar Bender Posted on 2012-02-27 08:04:02

    Hi Daniel, try contacting our customer service department they can help you determine what the issue is. 949-600-8642 or email service@axialracing.com

  42. Default_avatar hoopie Posted on 2012-03-08 20:41:45

    bender : at the top of the blog you told someone that you can run a 8.4v battery on the esc when i tryed it my truck cut out and started jumping when i tryed to run it it runs just fine with 7.2v so whats the deal

  43. Default_avatar Bender Posted on 2012-03-09 09:29:15

    It won’t hurt the ESC to run 8.4v, but you may experience some glitching in binds depending on the motor and servo you are running. A 55t motor with a moderate servo will probably be fine, but a 27t motor with a high torque servo will probably glitch quite a bit. Installing a BEC is the best way to avoid the issue all together.

  44. Default_avatar hoopie Posted on 2012-03-09 18:23:20

    is the servo on the rtr honcho high torque

  45. Default_avatar Bender Posted on 2012-03-12 09:18:36

    For an RTR is has a decent amount of torque, around 160oz if I remember right.

  46. Default_avatar Nick Posted on 2012-04-16 18:14:02

    I am thinking about manually adjusting my wraith’s drab brake but i was wondering if i had to remove the pinion gear before i did the adjusting?

  47. Default_avatar ScottinBend Posted on 2012-05-15 14:52:22

    Thanks for a great write up!

    I should have my new Wraith RTR waiting for me at home and I have a quick question. I plan on running a 7.2 NiMH, is it necessary to turn off the low-voltage cut-off?

    Thanks, and I love your writeup on the Wraith. It has helped me out lots!

    Scott

  48. Default_avatar Ed Schmidt Posted on 2012-06-08 10:05:18

    I am trying to program my esc, but I do not have a red or green light……they both light up….the red and green are on ??? what is up with that ???

  49. Default_avatar Bender Posted on 2012-06-12 09:09:36

    It’s not mandatory to turn off the lipo-cutoff when using NiCad or NiMH batteries. But, for best results/longer run time, you should set it to “off”. The ESC monitors battery pack voltage when the cut-off is turned on. With non-lipo packs the voltage will drop to a certain point, and the ESC will remove power at that threshold. But, chances are there is still some charge left in your battery. It’s just a safety feature to keep lipos at a safe minimum voltage, but NiCad and NiMH packs don’t need to be monitored.

  50. Default_avatar Bender Posted on 2012-06-12 09:10:40

    That is a first for me, I have never heard of that. Does the ESC currently work properly? I would try to call our customer service department and see if they can help you out. 1-877-642-9425

  51. Default_avatar stanmondz Posted on 2012-10-02 20:19:55

    can i run the ae2 in my xr10? i have 2 35t motors and a punk dig. also running on 2s

  52. Default_avatar Bender Posted on 2012-10-02 20:23:21

    I built an XR10 using our AE2 ESC and dual 55t motors, and it works great. You should be ok with 35t motors. If you get some glitching out of the steering servo in hard binds, you may need to add a Castle BEC.

  53. Default_avatar Stanmondz Posted on 2012-10-03 00:58:00

    I’m running a castle 10 amp bes

  54. Default_avatar Bender Posted on 2012-10-03 15:10:52

    You should be fine then.

  55. Default_avatar anthony Posted on 2012-11-01 15:19:40

    i just purchased my axial honcho rtr and i used it 4 times on 2s lipo, and after a couple runs i would lose forward/reverse and then it would kick back on, finally the esc just wouldnt turn on anymore. i read online that the on/off switch was faulty and so i opened it up and cleaned out the dirt and it fired up but now i have no steering/and no throttle, the lights work but the esc/or motor keep beeping and the lights grren and red keep flashing no matter what i do

  56. Default_avatar Dominic Posted on 2012-11-07 00:46:03

    my axial wraith does the same thing asanthonys what should i do

  57. Default_avatar Dominic Posted on 2012-11-07 23:58:28

    anthony

  58. Default_avatar Bender Posted on 2012-11-14 16:02:30

    Try contacting our customer service department. They can help you get things going again, 877-642-9425.

  59. Default_avatar Stephen Posted on 2013-01-04 22:02:31

    Hi I have a scx10 jeep and I ha e drove it about 10 times I got a light kit and put it in and they work great but I tried to drive and nothing I have steering but no drive or receser please help

  60. Default_avatar R.C Posted on 2013-01-06 07:46:35

    How do you reset the ESC

  61. Default_avatar mark Posted on 2013-02-24 11:31:08

    whawwhat is the low voltage cut of set at

  62. Default_avatar Axial Posted on 2013-03-26 10:10:11

    It is set to automatically detect when the lipo voltage drops below optimum conditions, regardless of the number of cells you’re running. I think the threshold is 3 volts per cell if I remember right.

Leave a Comment:

Name
Email
URL (optional)
Content